summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2016-04-05 21:18:43 +0200
committerLubomir Rintel <lkundrak@v3.sk>2016-04-05 22:22:58 +0200
commit9152dec99f479d82400f464ab47d45b8cbd8e0eb (patch)
treeb5d135bd5302fbb2757c3b0bf1052a7156b8115c /src/Makefile.am
parent29cfb144a8cdfce697c63175b1bfa36e0d95a6ad (diff)
downloadNetworkManager-9152dec99f479d82400f464ab47d45b8cbd8e0eb.tar.gz
build: disable deprecation checks for internal compilation
For internal compilation we want to be able to use deprecated API without warnings. Define the version min/max macros to effectively disable deprecation warnings. However, don't do it via CFLAGS option in the makefiles, instead hack it to "nm-default.h". After all, *every* source file that is for internal compilation needs to include this header as first.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 799e8c479f..bf668d748d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,8 +41,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/callouts \
-DPREFIX=\"$(prefix)\" \
-DG_LOG_DOMAIN=\""NetworkManager"\" \
- -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_INSIDE_DAEMON \
- -DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE
+ -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_INSIDE_DAEMON
# add each subdirectory that contains a libNM source file. $(sort) is being used
# primarily for its side effect of removing duplicates.