summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 0 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index 4f93dd3a9a..20145fba49 100644
--- a/meson.build
+++ b/meson.build
@@ -808,19 +808,6 @@ fi
content_files = []
-# FIXME: every plugin calls to this:
-'''
-set_sanitizer_env = \
- [ -n "$(SANITIZER_ENV)" ] && export $(SANITIZER_ENV) ; \
- if [ -n "$(1)" ] && echo $(CFLAGS) | grep -e -fsanitize=address ; then \
- export LD_PRELOAD="$${LD_PRELOAD}:$$(ldd $(1) | grep libasan\.so\.. -o | head -n 1)"; \
- fi
-
-check_so_symbols = \
- $(call set_sanitizer_env,$(1)); \
- LD_BIND_NOW=1 LD_PRELOAD=$${LD_PRELOAD}:$(1) $(builddir)/src/NetworkManager --version >/dev/null
-'''
-
subdir('introspection')
subdir('shared')
subdir('libnm-core')