summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 0 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index b3bb97189c..6942103f27 100644
--- a/meson.build
+++ b/meson.build
@@ -269,23 +269,6 @@ if dist_version != ''
endif
enable_wifi = get_option('wifi')
-if enable_wifi
- nl80211_src = '''
- #ifndef __user
- #define __user
- #endif
- #include <sys/types.h>
- #include <linux/types.h>
- #include <sys/socket.h>
- #include <linux/nl80211.h>
- int main() {
- int a = NL80211_RATE_INFO_BITRATE;
- a++;
- }
- '''
-
- assert(cc.compiles(nl80211_src), 'Linux kernel development header linux/nl80211.h not installed or not functional')
-endif
config_h.set10('WITH_WIFI', enable_wifi)
enable_iwd = get_option('iwd')