summaryrefslogtreecommitdiff
path: root/shared/c-stdaux/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'shared/c-stdaux/meson.build')
-rw-r--r--shared/c-stdaux/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/shared/c-stdaux/meson.build b/shared/c-stdaux/meson.build
new file mode 100644
index 0000000000..c8c5da536f
--- /dev/null
+++ b/shared/c-stdaux/meson.build
@@ -0,0 +1,15 @@
+project(
+ 'c-stdaux',
+ 'c',
+ version: '1',
+ license: 'Apache',
+ default_options: [
+ 'c_std=c11'
+ ],
+)
+project_description = 'Auxiliary macros and functions for the C standard library'
+
+add_project_arguments('-D_GNU_SOURCE', language: 'c')
+mod_pkgconfig = import('pkgconfig')
+
+subdir('src')