summaryrefslogtreecommitdiff
path: root/lib/libavtp/meson.build
diff options
context:
space:
mode:
authorAndre Guedes <andre.guedes@intel.com>2018-01-19 10:39:01 -0800
committerAndre Guedes <andre.guedes@intel.com>2018-01-26 18:00:09 -0800
commit145680dada729565c3ee82d30bfeaa861f1f1a1f (patch)
tree3e80c2f572eaa8083c4439e2425db6d03f12c33d /lib/libavtp/meson.build
parente6bd6c11453005069d1cc59a8a9d522ce65d830a (diff)
downloadOpen-AVB-145680dada729565c3ee82d30bfeaa861f1f1a1f.tar.gz
Add AAF support
This patch adds support for AVTP Audio Format (AAF) specified in chapter 7 from the IEEE 1722-2016 spec. AAF provides two data encapsulation: PCM and AES3. This patch implements only the PCM encapsulation. AAF is based on AVTP Stream PDU so this patch introduces the 'struct avtp_stream_pdu'. Since that PDU is also used by other AVTP Formats (e.g. IEC 61883/IIDC Format, Compressed Video Format, Time-Synchronous Control Format), the 'struct avtp_stream_pdu' is defined in avtp.h header. The public header avtp_aaf.h defines the AAF fields, their possible values, and get/set APIs to manipulate these fields.
Diffstat (limited to 'lib/libavtp/meson.build')
-rw-r--r--lib/libavtp/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/lib/libavtp/meson.build b/lib/libavtp/meson.build
index f5d29815..bdccb442 100644
--- a/lib/libavtp/meson.build
+++ b/lib/libavtp/meson.build
@@ -7,9 +7,15 @@ project(
library(
'avtp',
- 'src/avtp.c',
+ [
+ 'src/avtp.c',
+ 'src/avtp_aaf.c',
+ ],
include_directories: include_directories('include'),
install: true,
)
-install_headers('include/avtp.h')
+install_headers(
+ 'include/avtp.h',
+ 'include/avtp_aaf.h',
+)