summaryrefslogtreecommitdiff
path: root/lib/libavtp/meson.build
diff options
context:
space:
mode:
authorAndre Guedes <andre.guedes@intel.com>2018-01-19 10:35:45 -0800
committerAndre Guedes <andre.guedes@intel.com>2018-01-26 18:00:09 -0800
commite6bd6c11453005069d1cc59a8a9d522ce65d830a (patch)
tree87c42b27d35ff4967eea79218e4f2c02cd7fcaf1 /lib/libavtp/meson.build
parentd1ee5ba8a03a578c0b1aace651bbd84e0fc88d27 (diff)
downloadOpen-AVB-e6bd6c11453005069d1cc59a8a9d522ce65d830a.tar.gz
AVTP library initial commit
This patch adds the initial infrastructure to bootstrap the libavtp project. The goal of libavtp is to provide a standalone library that implements AVTP packetization so applications and AVB frameworks could use it instead of having their own AVTP packetization implementation.
Diffstat (limited to 'lib/libavtp/meson.build')
-rw-r--r--lib/libavtp/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/libavtp/meson.build b/lib/libavtp/meson.build
new file mode 100644
index 00000000..f5d29815
--- /dev/null
+++ b/lib/libavtp/meson.build
@@ -0,0 +1,15 @@
+project(
+ 'libavtp',
+ 'c',
+ version: '0.1',
+ license: 'BSD-3-Clause',
+)
+
+library(
+ 'avtp',
+ 'src/avtp.c',
+ include_directories: include_directories('include'),
+ install: true,
+)
+
+install_headers('include/avtp.h')