summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Davis <nitzmahone@users.noreply.github.com>2017-06-02 11:11:28 -0700
committerGitHub <noreply@github.com>2017-06-02 11:11:28 -0700
commit365d06c5389b669dd6b006c9b854b1f5720c5455 (patch)
tree1cfd9ec2dcbcddb32a26a48b54a61812568a8c36
parent99a30f8fdb19ce7ebc688ac36188271070fb023d (diff)
downloadansible-365d06c5389b669dd6b006c9b854b1f5720c5455.tar.gz
add Makefile target for single HTML page (#25313)
-rw-r--r--docs/docsite/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/docs/docsite/Makefile b/docs/docsite/Makefile
index 31e5895b10..321aed07b0 100644
--- a/docs/docsite/Makefile
+++ b/docs/docsite/Makefile
@@ -8,6 +8,11 @@ else
CPUS ?= $(shell nproc)
endif
+assertrst:
+ifndef rst
+ $(error specify document or pattern with rst=somefile.rst)
+endif
+
all: docs
docs: clean htmldocs
@@ -50,4 +55,8 @@ staticmin:
cat _themes/srtd/static/css/theme.css | sed -e 's/^[ ]*//g; s/[ ]*$$//g; s/\([:{;,]\) /\1/g; s/ {/{/g; s/\/\*.*\*\///g; /^$$/d' | sed -e :a -e '$$!N; s/\n\(.\)/\1/; ta' > _themes/srtd/static/css/theme.min.css
epub:
- (CPUS=$(CPUS) make -f Makefile.sphinx epub)
+ (CPUS=$(CPUS) make -f Makefile.sphinx epub)
+
+htmlsingle: assertrst
+ sphinx-build -j $(CPUS) -b html -d _build/doctrees ./rst _build/html rst/$(rst)
+ @echo "Output is in _build/html/$(rst)"