summaryrefslogtreecommitdiff
path: root/packaging/debian
diff options
context:
space:
mode:
authorEvgeni Golov <egolov@redhat.com>2016-03-18 11:07:23 +0100
committerEvgeni Golov <egolov@redhat.com>2016-03-18 11:07:23 +0100
commit0cdbc8b48da32ad706f89ffb58d09a27b8dd8965 (patch)
tree2ef193a815bf0a6291fadd8bf394926f72b3deff /packaging/debian
parentde2fe08d9f5db3509fa0f4c24c705f33f3a68340 (diff)
downloadansible-0cdbc8b48da32ad706f89ffb58d09a27b8dd8965.tar.gz
backwards compat for python-support on old Debian/Ubuntu releases
Diffstat (limited to 'packaging/debian')
-rw-r--r--packaging/debian/README.md7
-rw-r--r--packaging/debian/control2
-rwxr-xr-xpackaging/debian/rules3
3 files changed, 10 insertions, 2 deletions
diff --git a/packaging/debian/README.md b/packaging/debian/README.md
index 22e584ff5c..1561d854f8 100644
--- a/packaging/debian/README.md
+++ b/packaging/debian/README.md
@@ -4,11 +4,16 @@ Ansible Debian Package
To create an Ansible DEB package:
sudo apt-get install python-paramiko python-yaml python-jinja2 python-httplib2 python-setuptools python-six sshpass
- sudo apt-get install cdbs debhelper dpkg-dev git-core reprepro dh-python fakeroot asciidoc devscripts docbook-xml xsltproc libxml2-utils
+ sudo apt-get install cdbs debhelper dpkg-dev git-core reprepro fakeroot asciidoc devscripts docbook-xml xsltproc libxml2-utils
+ sudo apt-get install dh-python
git clone git://github.com/ansible/ansible.git
cd ansible
make deb
+On older releases that do not have `dh-python` (like Ubuntu 12.04), install `python-support` instead:
+
+ sudo apt-get install python-support
+
The debian package file will be placed in the `../` directory. This can then be added to an APT repository or installed with `dpkg -i <package-file>`.
Note that `dpkg -i` does not resolve dependencies.
diff --git a/packaging/debian/control b/packaging/debian/control
index e5dc2d4497..c6b699d798 100644
--- a/packaging/debian/control
+++ b/packaging/debian/control
@@ -3,7 +3,7 @@ Section: admin
Priority: optional
Standards-Version: 3.9.3
Maintainer: Ansible, Inc. <support@ansible.com>
-Build-Depends: cdbs, debhelper (>= 5.0.0), asciidoc, python, dh-python, python-setuptools
+Build-Depends: cdbs, debhelper (>= 5.0.0), asciidoc, python, dh-python | python-support, python-setuptools
Homepage: http://ansible.github.com/
Package: ansible
diff --git a/packaging/debian/rules b/packaging/debian/rules
index f5894b7a43..3ebffe5c83 100755
--- a/packaging/debian/rules
+++ b/packaging/debian/rules
@@ -2,6 +2,9 @@
# -- makefile --
DEB_PYTHON2_MODULE_PACKAGES=ansible
+ifneq ($(shell dpkg-query -f '$${Version}' -W python-support 2>/dev/null),)
+DEB_PYTHON_SYSTEM=pysupport
+endif
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk