summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatt Clay <matt@mystile.com>2023-05-01 11:03:10 -0700
committerGitHub <noreply@github.com>2023-05-01 11:03:10 -0700
commit6f4d3a79448a910b24d8fedb76009440551e4265 (patch)
tree227ea0f76b602a1c7a52157e5fb8c20043ce4b12 /pyproject.toml
parentc1e81778084da20f30a8188f0b7d1e0994d4f6f4 (diff)
downloadansible-6f4d3a79448a910b24d8fedb76009440551e4265.tar.gz
Backport setuptools fixes (#80684)
* Use package_data instead of include_package_data (#80652) This resolves warnings generated by setuptools such as the following: _Warning: Package 'ansible.galaxy.data' is absent from the `packages` configuration. (cherry picked from commit 5ac292e12d5e1515beb34028346d76bb68398fc8) * Set the minimum setuptools to 45.2.0 (#80649) Also update the package-data sanity test to use the minimum setuptools version. (cherry picked from commit 4d25e3d54f7de316c4f1d1575d2cf1ffa46b632c)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 482f222190..8a28c0b2ca 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,4 +1,4 @@
[build-system]
-requires = ["setuptools >= 39.2.0"]
+requires = ["setuptools >= 45.2.0"]
backend-path = ["packaging"] # requires 'Pip>=20' or 'pep517>=0.6.0'
build-backend = "pep517_backend.hooks" # wraps `setuptools.build_meta`