summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Martz <matt@sivel.net>2017-02-10 11:33:48 -0600
committerMatt Clay <matt@mystile.com>2017-02-11 16:04:52 -0800
commit87aa59af79fd2f8f74935795f60818bf0278cdc0 (patch)
treec6c48f7a4578a402905432ff6311d964e8d56c1b /setup.py
parent65e32243b832d297c7670f3538e41db65bdf9698 (diff)
downloadansible-87aa59af79fd2f8f74935795f60818bf0278cdc0.tar.gz
Legacy pep8 updates for setup.py and tests
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py90
1 files changed, 49 insertions, 41 deletions
diff --git a/setup.py b/setup.py
index 1bb0ee2f00..57088660d1 100644
--- a/setup.py
+++ b/setup.py
@@ -11,45 +11,53 @@ except ImportError:
" install setuptools).")
sys.exit(1)
-setup(name='ansible',
- version=__version__,
- description='Radically simple IT automation',
- author=__author__,
- author_email='info@ansible.com',
- url='http://ansible.com/',
- license='GPLv3',
- # Ansible will also make use of a system copy of python-six and
- # python-selectors2 if installed but use a Bundled copy if it's not.
- install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
- package_dir={ '': 'lib' },
- packages=find_packages('lib'),
- package_data={
- '': ['module_utils/*.ps1', 'modules/windows/*.ps1', 'modules/windows/*.ps1', 'galaxy/data/*/*.*', 'galaxy/data/*/*/*.*', 'galaxy/data/*/tests/inventory'],
- },
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Information Technology',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
- 'Natural Language :: English',
- 'Operating System :: POSIX',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Topic :: System :: Installation/Setup',
- 'Topic :: System :: Systems Administration',
- 'Topic :: Utilities',
- ],
- scripts=[
- 'bin/ansible',
- 'bin/ansible-playbook',
- 'bin/ansible-pull',
- 'bin/ansible-doc',
- 'bin/ansible-galaxy',
- 'bin/ansible-console',
- 'bin/ansible-connection',
- 'bin/ansible-vault',
- ],
- data_files=[],
+setup(
+ name='ansible',
+ version=__version__,
+ description='Radically simple IT automation',
+ author=__author__,
+ author_email='info@ansible.com',
+ url='http://ansible.com/',
+ license='GPLv3',
+ # Ansible will also make use of a system copy of python-six and
+ # python-selectors2 if installed but use a Bundled copy if it's not.
+ install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'],
+ package_dir={ '': 'lib' },
+ packages=find_packages('lib'),
+ package_data={
+ '': [
+ 'module_utils/*.ps1',
+ 'modules/windows/*.ps1',
+ 'modules/windows/*.ps1',
+ 'galaxy/data/*/*.*',
+ 'galaxy/data/*/*/*.*',
+ 'galaxy/data/*/tests/inventory'
+ ],
+ },
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Natural Language :: English',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: System :: Installation/Setup',
+ 'Topic :: System :: Systems Administration',
+ 'Topic :: Utilities',
+ ],
+ scripts=[
+ 'bin/ansible',
+ 'bin/ansible-playbook',
+ 'bin/ansible-pull',
+ 'bin/ansible-doc',
+ 'bin/ansible-galaxy',
+ 'bin/ansible-console',
+ 'bin/ansible-connection',
+ 'bin/ansible-vault',
+ ],
+ data_files=[],
)