summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Martz <matt@sivel.net>2020-08-17 13:45:41 -0500
committerGitHub <noreply@github.com>2020-08-17 13:45:41 -0500
commit959af7d90b34dfe530e27279db214ae2976c1f86 (patch)
tree20f4f286b60fc1a4fc756cfbf926dbf51dcd464c /setup.py
parentecea0185064b4ce8932917702a84962a75280fcf (diff)
downloadansible-959af7d90b34dfe530e27279db214ae2976c1f86.tar.gz
Don't do conflict check on sdist and egg_info (#71310)
* Don't do conflict check on sdist and egg_info. Fixes #71279 * Add changelog * adjust changelog PR link Co-authored-by: Rick Elrod <rick@elrod.me> * add warning about bdist_wheel Co-authored-by: Rick Elrod <rick@elrod.me>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 55dd2d357d..b15d4c966d 100644
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,14 @@ def _validate_install_ansible_base():
"""Validate that we can install ansible-base. Currently this only
cares about upgrading to ansible-base from ansible<2.10
"""
+ # Skip common commands we can ignore
+ # Do NOT add bdist_wheel here, we don't ship wheels
+ # and bdist_wheel is the only place we can prevent pip
+ # from installing, as pip creates a wheel, and installs the wheel
+ # and we have no influence over installation within a wheel
+ if set(('sdist', 'egg_info')).intersection(sys.argv):
+ return
+
if os.getenv('ANSIBLE_SKIP_CONFLICT_CHECK', '') not in ('', '0'):
return