diff options
author | Toshio Kuratomi <a.badger@gmail.com> | 2018-09-27 13:49:06 -0700 |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-09-27 13:49:06 -0700 |
commit | ccf41bb2feb602f611d73ff999e89e27fe8bc9bb (patch) | |
tree | 49a2a09f9e315d0db468926149320e93ef1fb9ba /setup.py | |
parent | 04ddadd89b614c1341c5cc52a0335900eb48d19b (diff) | |
download | ansible-ccf41bb2feb602f611d73ff999e89e27fe8bc9bb.tar.gz |
Update the minimum python versions to install (#46230)
* Update the minimum python versions to install
This will prevent modern pip from installing ansible-2.7.x in
python-2.6. Users will get the Ansible-2.6.x maintenance releases
instead.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -244,7 +244,7 @@ static_setup_params = dict( license='GPLv3+', # Ansible will also make use of a system copy of python-six and # python-selectors2 if installed but use a Bundled copy if it's not. - python_requires='>=2.6,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*', + python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*', package_dir={'': 'lib'}, packages=find_packages('lib'), package_data={ @@ -270,8 +270,9 @@ static_setup_params = dict( 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)', 'Natural Language :: English', 'Operating System :: POSIX', - 'Programming Language :: Python :: 2.6', + 'Programming Language :: Python :: 2', 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', 'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.7', |