summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Davis <nitzmahone@users.noreply.github.com>2020-03-23 13:07:33 -0700
committerGitHub <noreply@github.com>2020-03-23 13:07:33 -0700
commited9de94ad92dcc07ea3863808e0f4b00f2402cea (patch)
treedfae6830186bb6d4c4da01284d4caf5f6d477eb2 /setup.py
parentf1b3e8364ea4556b6ab74b017c5fc7bd076bd1b6 (diff)
downloadansible-ed9de94ad92dcc07ea3863808e0f4b00f2402cea.tar.gz
remove azure extras and extras_require support (#67822)
* remove azure extras and extras_require support * Since Azure will be collectionized, the requirements will float more frequently than Ansible releases; the Azure collection needs to host the requirements now. * Removed the dynamic extras support as well, since Azure was the only thing using it. If we need it again, it's easy to pull back from history. * Mark azure-requirements as orhpaned. This keeps the docs around so that existing links from old test runs remain valid. Co-authored-by: Matt Clay <matt@mystile.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 6fcc4b3e82..ced8c8baaf 100644
--- a/setup.py
+++ b/setup.py
@@ -236,22 +236,6 @@ def substitute_crypto_to_req(req):
return [r for r in req if is_not_crypto(r)] + [crypto_backend]
-def read_extras():
- """Specify any extra requirements for installation."""
- extras = dict()
- extra_requirements_dir = 'packaging/requirements'
- for extra_requirements_filename in os.listdir(extra_requirements_dir):
- filename_match = re.search(r'^requirements-(\w*).txt$', extra_requirements_filename)
- if not filename_match:
- continue
- extra_req_file_path = os.path.join(extra_requirements_dir, extra_requirements_filename)
- try:
- extras[filename_match.group(1)] = read_file(extra_req_file_path).splitlines()
- except RuntimeError:
- pass
- return extras
-
-
def get_dynamic_setup_params():
"""Add dynamically calculated setup params to static ones."""
return {
@@ -260,7 +244,6 @@ def get_dynamic_setup_params():
'install_requires': substitute_crypto_to_req(
read_requirements('requirements.txt'),
),
- 'extras_require': read_extras(),
}