diff options
author | Toshio Kuratomi <a.badger@gmail.com> | 2018-04-09 10:46:41 -0700 |
---|---|---|
committer | Toshio Kuratomi <a.badger@gmail.com> | 2018-04-09 11:59:55 -0700 |
commit | 988808c066e343e65ccfed2ebd0e5806e90fc9b8 (patch) | |
tree | 23994d95eade92bbca11993b02979f305a0d1c2b /setup.py | |
parent | 6300e71903ef02212f792b09c9b6720a55bfdf24 (diff) | |
download | ansible-988808c066e343e65ccfed2ebd0e5806e90fc9b8.tar.gz |
README.rst should always exist so no need to set a default value
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 3 insertions, 11 deletions
@@ -158,17 +158,9 @@ for extra_requirements_filename in os.listdir(extra_requirements_dir): with open(os.path.join(extra_requirements_dir, extra_requirements_filename)) as extra_requirements_file: extra_requirements[filename_match.group(1)] = extra_requirements_file.read().splitlines() -try: - with open('README.rst', 'r') as readme_file: - longdesc = readme_file.read() -except (IOError, OSError): - longdesc = ('Ansible is a radically simple IT automation system. It handles' - ' configuration-management, application deployment, cloud provisioning, ad-hoc' - ' task-execution, and multinode orchestration - including trivializing things like' - ' zero-downtime rolling updates with load balancers.\n' - '\n' - 'Read the documentation and more at https://ansible.com/' - ) +# Retrieve the long description from the README +with open('README.rst', 'r') as readme_file: + longdesc = readme_file.read() setup( # Use the distutils SDist so that symlinks are not expanded |