diff options
author | Toshio Kuratomi <a.badger@gmail.com> | 2017-02-01 08:48:23 -0800 |
---|---|---|
committer | Toshio Kuratomi <a.badger@gmail.com> | 2017-02-03 08:23:50 -0800 |
commit | d1a6b07fe1ceb8099abf763ac7e4bb4ebfaf1d3f (patch) | |
tree | 2172aefaa130a443ac5b72c61c28498416be6c49 /setup.py | |
parent | 2c70450e230f868ec41d2548a7de96c599a99242 (diff) | |
download | ansible-d1a6b07fe1ceb8099abf763ac7e4bb4ebfaf1d3f.tar.gz |
Move ssh and local connection plugins from using raw select to selectors
At the moment, this change will use EPoll on Linux, KQueue on *BSDs,
etc, so it should alleviate problems with too many open file
descriptors.
* Bundle a copy of selectors2 so that we have the selectors API everywhere.
* Add licensing information to selectors2 file so it's clear what the
licensing terms and conditions are.
* Exclude the bundled copy of selectors2 from our boilerplate code-smell test
* Rewrite ssh_run tests to attempt to work around problem with mocking
select on shippable
Fixes #14143
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -18,8 +18,8 @@ setup(name='ansible', author_email='info@ansible.com', url='http://ansible.com/', license='GPLv3', - # Ansible will also make use of a system copy of python-six if installed but use a - # Bundled copy if it's not. + # Ansible will also make use of a system copy of python-six and + # python-selectors2 if installed but use a Bundled copy if it's not. install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'], package_dir={ '': 'lib' }, packages=find_packages('lib'), |