diff options
author | James Cammarata <jimi@sngx.net> | 2014-04-29 14:41:57 -0500 |
---|---|---|
committer | James Cammarata <jimi@sngx.net> | 2014-04-29 14:41:57 -0500 |
commit | 6879415f252f7bb1931934befd6fc6690e1b6424 (patch) | |
tree | 8f07abf226232404fb818c52b8f6295993842ffa /setup.py | |
parent | cff4b5d412a114094f2624257cfe6e89160ae353 (diff) | |
parent | ff7492c2cc008110b890f320b10747bbae4f9b6a (diff) | |
download | ansible-6879415f252f7bb1931934befd6fc6690e1b6424.tar.gz |
Merge branch 'feature/multi-version-import' of https://github.com/abadger/ansible into abadger-feature/multi-version-import
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 12 insertions, 2 deletions
@@ -6,7 +6,17 @@ from glob import glob sys.path.insert(0, os.path.abspath('lib')) from ansible import __version__, __author__ -from distutils.core import setup +try: + from setuptools import setup + raise ImportError +except ImportError: + print(''' +ansible now needs setuptools in order to build. + +Some scripts now need setuptools installed in order to run. + ''') + raise + # find library modules from ansible.constants import DEFAULT_MODULE_PATH @@ -29,7 +39,7 @@ setup(name='ansible', author_email='michael@ansible.com', url='http://ansible.com/', license='GPLv3', - install_requires=['paramiko', 'jinja2', "PyYAML"], + install_requires=['paramiko', 'jinja2', "PyYAML", 'setuptools', 'pycrypto >= 2.6'], package_dir={ 'ansible': 'lib/ansible' }, packages=[ 'ansible', |