summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <michael.dehaan@gmail.com>2014-09-26 11:25:56 -0400
committerMichael DeHaan <michael.dehaan@gmail.com>2014-09-26 11:25:56 -0400
commite5116d2f9bd851949ae50e0c9c112750e7cec761 (patch)
tree197cfddc7f64bc5f3228c344f56b81f548c15a1a /setup.py
parentf35ed8a6c0dc81b86c69348fff543d52f070ee28 (diff)
downloadansible-e5116d2f9bd851949ae50e0c9c112750e7cec761.tar.gz
changes for package loading of modules
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 1 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index de4b251fee..872dbefadb 100644
--- a/setup.py
+++ b/setup.py
@@ -13,20 +13,6 @@ except ImportError:
"Install it using your package manager (usually python-setuptools) or via pip (pip install setuptools)."
sys.exit(1)
-# find library modules
-from ansible.constants import DEFAULT_MODULE_PATH
-module_paths = DEFAULT_MODULE_PATH.split(os.pathsep)
-# always install in /usr/share/ansible if specified
-# otherwise use the first module path listed
-if '/usr/share/ansible' in module_paths:
- install_path = '/usr/share/ansible'
-else:
- install_path = module_paths[0]
-dirs=os.listdir("./library/")
-data_files = []
-for i in dirs:
- data_files.append((os.path.join(install_path, i), glob('./library/' + i + '/*')))
-
setup(name='ansible',
version=__version__,
description='Radically simple IT automation',
@@ -64,5 +50,5 @@ setup(name='ansible',
'bin/ansible-galaxy',
'bin/ansible-vault',
],
- data_files=data_files
+ data_files=[],
)