summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fc9276b509..5a89327a3f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
import os
+import os.path
import sys
sys.path.insert(0, os.path.abspath('lib'))
@@ -18,6 +19,25 @@ with open('requirements.txt') as requirements_file:
"That indicates this copy of the source code is incomplete.")
sys.exit(2)
+SYMLINKS = {'ansible': frozenset(('ansible-console',
+ 'ansible-doc',
+ 'ansible-galaxy',
+ 'ansible-playbook',
+ 'ansible-pull',
+ 'ansible-vault'))}
+
+for source in SYMLINKS:
+ for dest in SYMLINKS[source]:
+ dest_path = os.path.join('bin', dest)
+ if not os.path.islink(dest_path):
+ try:
+ os.unlink(dest_path)
+ except OSError as e:
+ if e.errno == 2:
+ # File does not exist which is all we wanted
+ pass
+ os.symlink(source, dest_path)
+
setup(
name='ansible',
version=__version__,