summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 11 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 08b0f253b1..31bfe3137a 100644
--- a/setup.py
+++ b/setup.py
@@ -162,7 +162,8 @@ for extra_requirements_filename in os.listdir(extra_requirements_dir):
with open('README.rst', 'r') as readme_file:
longdesc = readme_file.read()
-setup(
+
+setup_params = dict(
# Use the distutils SDist so that symlinks are not expanded
# Use a custom Build for the same reason
cmdclass={
@@ -240,3 +241,12 @@ setup(
# Installing as zip files would break due to references to __file__
zip_safe=False
)
+
+
+def main():
+ """Invoke installation process using setuptools."""
+ setup(**setup_params)
+
+
+if __name__ == '__main__':
+ main()