summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index ba874baf59..44cf7224d6 100644
--- a/setup.py
+++ b/setup.py
@@ -158,6 +158,17 @@ for extra_requirements_filename in os.listdir(extra_requirements_dir):
with open(os.path.join(extra_requirements_dir, extra_requirements_filename)) as extra_requirements_file:
extra_requirements[filename_match.group(1)] = extra_requirements_file.read().splitlines()
+try:
+ with open('README.rst', 'r') as readme_file:
+ longdesc = readme_file.read()
+except (IOError, OSError):
+ longdesc = ('Ansible is a radically simple IT automation system. It handles'
+ ' configuration-management, application deployment, cloud provisioning, ad-hoc'
+ ' task-execution, and multinode orchestration - including trivializing things like'
+ ' zero-downtime rolling updates with load balancers.\n'
+ '\n'
+ 'Read the documentation and more at https://ansible.com/'
+ )
setup(
# Use the distutils SDist so that symlinks are not expanded
@@ -172,6 +183,7 @@ setup(
name='ansible',
version=__version__,
description='Radically simple IT automation',
+ long_description=longdesc,
author=__author__,
author_email='info@ansible.com',
url='https://ansible.com/',