summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2023-01-11 09:44:46 +0000
committerJoe Orton <jorton@apache.org>2023-01-11 09:44:46 +0000
commite67c1792d460fd8f50fec59cbf828fbff748aa5a (patch)
treef513d6148f1dd21bef580b659aea5d1ae6e03351 /configure.in
parent3c446343a88024251027c91cc21609034944ba6e (diff)
downloadapr-e67c1792d460fd8f50fec59cbf828fbff748aa5a.tar.gz
Merge r1906594 from trunk:
Fix further strict C99 compliance issue. (fixes #37) PR: 66408 Submitted by: Sam James <sam gentoo.org> git-svn-id: https://svn.apache.org/repos/asf/apr/apr/branches/1.7.x@1906595 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1cdc4653a..20dfc9de8 100644
--- a/configure.in
+++ b/configure.in
@@ -1562,8 +1562,6 @@ AC_CHECK_FUNCS(sigaction, [ have_sigaction="1" ], [ have_sigaction="0" ])
AC_DECL_SYS_SIGLIST
AC_CHECK_FUNCS(fork, [ fork="1" ], [ fork="0" ])
-APR_CHECK_INET_ADDR
-APR_CHECK_INET_NETWORK
AC_SUBST(apr_inaddr_none)
AC_CHECK_FUNC(_getch)
AC_CHECK_FUNCS(strerror_r, [ strerror_r="1" ], [ strerror_r="0" ])
@@ -1669,6 +1667,9 @@ APR_FLAG_HEADERS(
sys/un.h \
sys/wait.h)
+APR_CHECK_INET_ADDR
+APR_CHECK_INET_NETWORK
+
# IRIX 6.5 has a problem in <netinet/tcp.h> which prevents it from
# being included by itself. Check for <netinet/tcp.h> manually,
# including another header file first.
@@ -2371,7 +2372,7 @@ AC_TRY_RUN([
#ifndef SEM_FAILED
#define SEM_FAILED (-1)
#endif
-main()
+int main()
{
sem_t *psem;
const char *sem_name = "/apr_autoconf";
@@ -2568,6 +2569,8 @@ int fd;
struct flock proc_mutex_lock_it = {0};
const char *fname = "conftest.fcntl";
+int lockit();
+
int main()
{
int rc, status;;