summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGraham Leggett <minfrin@apache.org>2019-08-23 22:16:29 +0000
committerGraham Leggett <minfrin@apache.org>2019-08-23 22:16:29 +0000
commita67db412f2b2c92d55a1576ab4af285fc865d556 (patch)
tree7010a3eb7e74ffc182a104dfd5e9d9fe67345b74 /configure.in
parent682f0d6d094af44f2d4bce02504504b7cb0d4fd0 (diff)
downloadapr-a67db412f2b2c92d55a1576ab4af285fc865d556.tar.gz
Backport 1865343
Add --tag=CC to libtool invocations. PR 62640. [Michael Osipov] git-svn-id: https://svn.apache.org/repos/asf/apr/apr/branches/1.7.x@1865793 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6833b32d0..85df7abba 100644
--- a/configure.in
+++ b/configure.in
@@ -283,9 +283,9 @@ AC_ARG_WITH(libtool, [ --without-libtool avoid using libtool to link the
[ use_libtool=$withval ], [ use_libtool="yes" ] )
if test "x$use_libtool" = "xyes"; then
- lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
+ lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile --tag=CC $(COMPILE) -o $@ -c $< && touch $@'
LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(COMPILE) \$(LT_LDFLAGS) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
+ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link --tag=CC \$(COMPILE) \$(LT_LDFLAGS) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
so_ext='lo'
lib_target='-rpath $(libdir) $(OBJECTS)'
export_lib_target='-rpath \$(libdir) \$(OBJECTS)'