summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2006-03-10 10:09:36 +0000
committerJoe Orton <jorton@apache.org>2006-03-10 10:09:36 +0000
commit4418278803c972d939a498598fce717d4493a3c2 (patch)
tree8607eb40ed38d8c9d144aa4ca74162910944b60d /configure.in
parenta2291bb0ac25fdcb14fdad33485e2045758d4c49 (diff)
downloadapr-4418278803c972d939a498598fce717d4493a3c2.tar.gz
* configure.in: Set LT_NO_INSTALL to -no-install on all platforms but
Darwin. * test/Makefile.in: Revert r384715 and use LT_NO_INSTALL instead of hard-coding -no-install. git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@384750 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 999517e53..15850a195 100644
--- a/configure.in
+++ b/configure.in
@@ -2047,6 +2047,16 @@ AC_SUBST(DEFAULT_OSDIR)
AC_SUBST(EXEEXT)
AC_SUBST(LIBTOOL_LIBS)
+# Use -no-install to link the test programs on all platforms
+# but Darwin, where it would cause the programs to be linked
+# against installed versions of libapr instead of those just
+# built.
+case $host in
+*-apple-darwin*) LT_NO_INSTALL="" ;;
+*) LT_NO_INSTALL="-no-install" ;;
+esac
+AC_SUBST(LT_NO_INSTALL)
+
#
# BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
#