summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2005-08-24 15:37:45 +0000
committerJoe Orton <jorton@apache.org>2005-08-24 15:37:45 +0000
commit71a83632c4a6482c4dbbfa426e56d1f09b5f65cb (patch)
treec5293b83c6211e91c650052462ed4bb119296a50 /configure.in
parent5daf131bb26c2d53afd7f99f7164c19e5266b7ad (diff)
downloadapr-71a83632c4a6482c4dbbfa426e56d1f09b5f65cb.tar.gz
* configure.in: Fix checks for alloca().
PR: 13037 Submitted by: Noah Misch <noah cs.caltech.edu> git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@239697 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9115013a0..8fbe420fd 100644
--- a/configure.in
+++ b/configure.in
@@ -883,7 +883,10 @@ AC_SUBST(sharedmem)
dnl ----------------------------- Checks for Any required Functions
dnl Checks for library functions. (N.B. poll is further down)
-AC_CHECK_FUNCS([alloca calloc setsid isinf isnan \
+
+AC_FUNC_ALLOCA
+
+AC_CHECK_FUNCS([calloc setsid isinf isnan \
getenv putenv setenv unsetenv \
writev getifaddrs utime utimes])
AC_CHECK_FUNCS(setrlimit, [ have_setrlimit="1" ], [ have_setrlimit="0" ])
@@ -973,7 +976,6 @@ dnl ----------------------------- Checks for Any required Headers
AC_HEADER_STDC
APR_FLAG_HEADERS(
- alloca.h \
ByteOrder.h \
conio.h \
crypt.h \