summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilfredo Sanchez <wsanchez@apache.org>2001-04-19 07:18:47 +0000
committerWilfredo Sanchez <wsanchez@apache.org>2001-04-19 07:18:47 +0000
commit5d23f251553efdc3eb86e63bc140949dfd263dcf (patch)
treeb8c69542edd459859acda96569a12d87d17e301f /configure.in
parent1b2212b698ee889ccc82b1768ede6541bf8cef82 (diff)
downloadapr-5d23f251553efdc3eb86e63bc140949dfd263dcf.tar.gz
Clean up conditionals in unix DSO code so that we decide based on the
dynamic loading implementation, which we noticed at configure time, instead of by operating system, which should be simpler to maintain. git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@61534 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 42e6b3f92..74fefc240 100644
--- a/configure.in
+++ b/configure.in
@@ -780,19 +780,19 @@ AC_ARG_ENABLE(dso,
[ --enable-dso Enable dso support ],
[ tempdso=$enableval],
[
- AC_CHECK_FUNCS(NSLinkModule, [ tempdso="yes" ], [ tempdso="no" ])
+ AC_CHECK_FUNCS(NSLinkModule, [ tempdso="dyld" ], [ tempdso="no" ])
if test "$tempdso" = "no"; then
- AC_CHECK_LIB(dl, dlopen, [ tempdso="yes" LIBS="$LIBS -ldl" ],
+ AC_CHECK_LIB(dl, dlopen, [ tempdso="dlfcn" LIBS="$LIBS -ldl" ],
tempdso="no")
fi
if test "$tempdso" = "no"; then
- AC_CHECK_FUNCS(dlopen, [ tempdso="yes" ], [ tempdso="no" ])
+ AC_CHECK_FUNCS(dlopen, [ tempdso="dlfcn" ], [ tempdso="no" ])
fi
if test "$tempdso" = "no"; then
AC_CHECK_LIB(root, load_image, tempdso="yes", tempdso="no")
fi
if test "$tempdso" = "no"; then
- AC_CHECK_LIB(dld, shl_load, [ tempdso="yes" LIBS="$LIBS -ldld" ],
+ AC_CHECK_LIB(dld, shl_load, [ tempdso="shl" LIBS="$LIBS -ldld" ],
tempdso="no")
fi
if test "$tempdso" = "no"; then
@@ -807,6 +807,11 @@ AC_ARG_ENABLE(dso,
if test "$tempdso" = "no"; then
aprdso="0"
else
+ case "$tempdso" in
+ dlfcn) AC_DEFINE(DSO_USE_DLFCN);;
+ shl) AC_DEFINE(DSO_USE_SHL);;
+ dyld) AC_DEFINE(DSO_USE_DYLD);;
+ esac
aprdso="1"
apr_modules="$apr_modules dso"
fi