summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2015-03-25 10:51:43 +0000
committerRichard Hughes <richard@hughsie.com>2015-03-25 11:07:48 +0000
commit97e6abea4af61983f5706ec81cd2d53fdd0b76d1 (patch)
tree85d2aae961bcf47ef8000c22aaf1cc0bba4ca878 /Makefile.am
parent250b95f19db2df5b7143247e2d711af5bf4d17c3 (diff)
downloadappstream-glib-97e6abea4af61983f5706ec81cd2d53fdd0b76d1.tar.gz
Make the AppStream builder support optional
99% of the time we don't need all the deps for the builder, and for embedded images we should not build it at all.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index de6d6a6..04084a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,12 +2,19 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = \
libappstream-glib \
- libappstream-builder \
- client \
data \
docs \
po
+if HAVE_BUILDER
+SUBDIRS += \
+ libappstream-builder
+endif
+
+# depends on libappstream-builder
+SUBDIRS += \
+ client
+
DISTCLEANFILES = \
appstream-glib-*.tar.xz
@@ -67,6 +74,7 @@ ChangeLog:
DISTCHECK_CONFIGURE_FLAGS = \
--enable-dep11 \
+ --enable-builder \
--with-bashcompletiondir=/${prefix}/share/bash-completion/completions
.PHONY: ChangeLog