summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2015-01-23 12:02:19 +0000
committerRichard Hughes <richard@hughsie.com>2015-01-23 12:52:23 +0000
commit02f8bf4faaf5cd3e3036af9768f4d5c5ee2b7109 (patch)
tree5a4afce65c919918135285067d942c627a261b73 /configure.ac
parent049899027a5a62e9c7f1ac817dccf6f1751ea7ac (diff)
downloadappstream-glib-02f8bf4faaf5cd3e3036af9768f4d5c5ee2b7109.tar.gz
Add OSTree support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e11a6d..fb9ef06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,22 @@ PKG_CHECK_MODULES(GDKPIXBUF, gdk-pixbuf-2.0 >= 2.14 gtk+-3.0)
PKG_CHECK_MODULES(SQLITE, sqlite3)
PKG_CHECK_MODULES(FREETYPE, pango fontconfig freetype2 >= 9.10.0)
+# ostree (default enabled)
+AC_ARG_ENABLE(ostree, AS_HELP_STRING([--disable-ostree],[Disable ostree support]), enable_ostree=$enableval)
+if test x$enable_ostree != xno; then
+ PKG_CHECK_MODULES(OSTREE, ostree-1 >= 2015.1, HAVE_OSTREE="yes", HAVE_OSTREE="no")
+ if test "x$HAVE_OSTREE" = "xyes"; then
+ AC_DEFINE(HAVE_OSTREE, 1, [define if OSTREE is installed])
+ else
+ if test x$enable_ostree = xyes; then
+ AC_MSG_ERROR([ostree enabled but not found])
+ fi
+ fi
+else
+ HAVE_OSTREE=no
+fi
+AM_CONDITIONAL(HAVE_OSTREE, test x$HAVE_OSTREE = xyes)
+
# rpm (default enabled)
AC_ARG_ENABLE(rpm, AS_HELP_STRING([--disable-rpm],[Disable rpm support]), enable_rpm=$enableval)
if test x$enable_rpm != xno; then