summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2014-06-18 19:40:50 +0100
committerRichard Hughes <richard@hughsie.com>2014-06-18 21:35:22 +0100
commit0a389b1566567a60fafcc9d729660c9eb740659a (patch)
tree9da7dfbce0b16293fd4fe3a72dceefa1ec1bf79e /configure.ac
parent124d8e81235b34f65541f060e23c5079411c17fc (diff)
downloadappstream-glib-0a389b1566567a60fafcc9d729660c9eb740659a.tar.gz
Add manpages for appstream-util and appstream-builder
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f85dd08..33b57e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,28 @@ else
fi
AM_CONDITIONAL(HAVE_RPM, test x$HAVE_RPM = xyes)
+# man files
+AC_ARG_ENABLE(man,
+ [AS_HELP_STRING([--disable-man],
+ [Disable building man page])],,
+ enable_man=maybe)
+AS_IF([test "x$enable_man" != "xno"],
+ [AC_CHECK_PROG([have_xsltproc], [xsltproc], [yes], [no])
+ JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.3//EN],
+ [DocBook XML DTD V4.3], [have_docbookdtd=yes], [have_docbookdtd=no])
+ JH_CHECK_XML_CATALOG(
+ [http://docbook.sourceforge.net/release/xsl/current/html/refentry.xsl],
+ [DocBook XSL Stylesheets], [have_docbookxsl=yes], [have_docbookxsl=no])
+ AS_IF([test "x$have_xsltproc" = "xyes" -a "x$have_docbookdtd" = "xyes" \
+ -a "x$have_docbookxsl" = "xyes"],
+ [have_manutils=yes],
+ [AS_IF([test "x$enable_man" = "xyes"],
+ [AC_MSG_ERROR(
+ [manpage generation requested but required utilities were not found])])
+ have_manutils=no])],
+ [have_manutils=no])
+AM_CONDITIONAL([ENABLE_MAN], [test "x$have_manutils" = "xyes"])
+
AC_CONFIG_FILES([
Makefile
client/Makefile