summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2014-03-21 20:28:50 +0000
committerRichard Hughes <richard@hughsie.com>2014-08-20 10:01:26 +0100
commitc63ae20cbbfe7e241fca2775f4df05da85335d13 (patch)
treee8f3a00955a29eb6ad285b2d6bf93bdb06c73601 /configure.ac
parent451a7489300e19221bb5bed6da182839e2e3ad69 (diff)
downloadappstream-glib-c63ae20cbbfe7e241fca2775f4df05da85335d13.tar.gz
Use libyaml to read DEP-11 metadata
This is optional, but enabled by default. Use --disable-dep11 to remove the libyaml dependancy.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbabd97..4dd97bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,19 @@ AS_IF([test "x$enable_man" != "xno"],
[have_manutils=no])
AM_CONDITIONAL([ENABLE_MAN], [test "x$have_manutils" = "xyes"])
+dnl ---------------------------------------------------------------------------
+dnl - Use libyaml for DEP-11 support
+dnl ---------------------------------------------------------------------------
+AC_ARG_ENABLE(dep11, AS_HELP_STRING([--enable-dep11],[enable DEP-11]),
+ enable_dep11=$enableval,enable_dep11=yes)
+AM_CONDITIONAL(HAVE_DEP11, test x$enable_dep11 = xyes)
+if test x$enable_dep11 = xyes; then
+ AC_CHECK_HEADER(yaml.h, [], [AC_MSG_ERROR([No yaml.h])])
+ YAML_LIBS="-lyaml"
+ AC_SUBST(YAML_LIBS)
+ AC_DEFINE(PK_BUILD_DEP11,1,[Build DEP-11 code])
+fi
+
AC_CONFIG_FILES([
Makefile
client/Makefile
@@ -193,5 +206,6 @@ AC_MSG_RESULT([
datarootdir: ${datarootdir}
includedir: ${includedir}
lib dir: ${libdir}
+ DEP-11 support: ${enable_dep11}
Bash completion dir: ${with_bashcompletiondir}
])