summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2016-08-24 12:20:51 +0100
committerRichard Hughes <richard@hughsie.com>2017-05-10 12:44:02 +0100
commit8122b447e5c85a7addfc19827232d5cfe85b4eba (patch)
tree8c277f330485f7e4ad945c048a7e2687e03a3bbc /data/meson.build
parentfe18fd82266a0ff1f744d3ae287dc312e09549fa (diff)
downloadappstream-glib-8122b447e5c85a7addfc19827232d5cfe85b4eba.tar.gz
Switch to the meson build system.
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build73
1 files changed, 73 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..5107f8e
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,73 @@
+subdir('installed-tests')
+subdir('tests')
+
+install_data('appstream-xml.m4', install_dir : 'share/aclocal')
+install_data('appstream-util', install_dir : 'share/bash-completion/completions')
+
+if get_option('enable-builder')
+install_data('appstream-builder', install_dir : 'share/bash-completion/completions')
+endif
+
+install_data('appdata.its', install_dir : 'share/gettext/its')
+install_data('appdata.loc', install_dir : 'share/gettext/its')
+
+xsltproc = find_program('xsltproc', required : false)
+if xsltproc.found()
+ custom_target('appstream-util-man',
+ input: 'appstream-util.xml',
+ output: 'appstream-util.1',
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'),
+ command: [
+ xsltproc,
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ '-o', '@OUTPUT@',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@'
+ ]
+ )
+ custom_target('appstream-compose-man',
+ input: 'appstream-compose.xml',
+ output: 'appstream-compose.1',
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'),
+ command: [
+ xsltproc,
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ '-o', '@OUTPUT@',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@'
+ ]
+ )
+ if get_option('enable-builder')
+ custom_target('appstream-builder-man',
+ input: 'appstream-builder.xml',
+ output: 'appstream-builder.1',
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'),
+ command: [
+ xsltproc,
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ '-o', '@OUTPUT@',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@'
+ ]
+ )
+ endif
+endif
+