summaryrefslogtreecommitdiff
path: root/libappstream-glib/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2014-06-26 13:31:16 +0100
committerRichard Hughes <richard@hughsie.com>2014-06-26 15:18:09 +0100
commitad5a6b7eeed8c602877a4dc9822165d226ac2d39 (patch)
tree7ffc008d56f724f34bc404e1605bf86ef2784f17 /libappstream-glib/Makefile.am
parent5636dfb4d5aba5fbd869fbfe58918cd9c3a0a3f2 (diff)
downloadappstream-glib-ad5a6b7eeed8c602877a4dc9822165d226ac2d39.tar.gz
Add as_utils_is_blacklisted_id()
This moves the data to libappstream-glib where we can use it to prevent parsing desktop files that should not be shown in the software center.
Diffstat (limited to 'libappstream-glib/Makefile.am')
-rw-r--r--libappstream-glib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/libappstream-glib/Makefile.am b/libappstream-glib/Makefile.am
index 09d3bc1..43f0981 100644
--- a/libappstream-glib/Makefile.am
+++ b/libappstream-glib/Makefile.am
@@ -26,7 +26,7 @@ as-tag-private.h: as-tag.gperf
$(AM_V_GEN) gperf < $< > $@
endif
-as-resources.c: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt
+as-resources.c: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt as-blacklist-ids.txt
$(AM_V_GEN) \
glib-compile-resources \
--sourcedir=$(srcdir) \
@@ -35,7 +35,7 @@ as-resources.c: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.t
--generate-source \
--c-name as \
$(srcdir)/appstream-glib.gresource.xml
-as-resources.h: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt
+as-resources.h: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt as-blacklist-ids.txt
$(AM_V_GEN) \
glib-compile-resources \
--sourcedir=$(srcdir) \
@@ -183,6 +183,7 @@ DISTCLEANFILES = \
EXTRA_DIST = \
appstream-glib.gresource.xml \
appstream-glib.pc.in \
+ as-blacklist-ids.txt \
as-license-ids.txt \
as-stock-icons.txt \
as-tag.gperf \