summaryrefslogtreecommitdiff
path: root/libappstream-glib/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2014-07-29 15:22:51 +0100
committerRichard Hughes <richard@hughsie.com>2014-07-29 15:22:51 +0100
commit53965c8a671627ce9132f99bee45e51d38b0bc83 (patch)
tree2bbca4445cb62984af5b645f89a1333e904fea42 /libappstream-glib/Makefile.am
parent361ac14eb59c891c46db4e343454ee0b4113fb8a (diff)
downloadappstream-glib-53965c8a671627ce9132f99bee45e51d38b0bc83.tar.gz
Only add registered projects and categories to the metadata
Diffstat (limited to 'libappstream-glib/Makefile.am')
-rw-r--r--libappstream-glib/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/libappstream-glib/Makefile.am b/libappstream-glib/Makefile.am
index 43f0981..eeb0ca0 100644
--- a/libappstream-glib/Makefile.am
+++ b/libappstream-glib/Makefile.am
@@ -26,7 +26,12 @@ as-tag-private.h: as-tag.gperf
$(AM_V_GEN) gperf < $< > $@
endif
-as-resources.c: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt as-blacklist-ids.txt
+as-resources.c: appstream-glib.gresource.xml \
+ as-stock-icons.txt \
+ as-license-ids.txt \
+ as-blacklist-ids.txt \
+ as-category-ids.txt \
+ as-environment-ids.txt
$(AM_V_GEN) \
glib-compile-resources \
--sourcedir=$(srcdir) \
@@ -35,7 +40,12 @@ as-resources.c: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.t
--generate-source \
--c-name as \
$(srcdir)/appstream-glib.gresource.xml
-as-resources.h: appstream-glib.gresource.xml as-stock-icons.txt as-license-ids.txt as-blacklist-ids.txt
+as-resources.h: appstream-glib.gresource.xml \
+ as-stock-icons.txt \
+ as-license-ids.txt \
+ as-blacklist-ids.txt \
+ as-category-ids.txt \
+ as-environment-ids.txt
$(AM_V_GEN) \
glib-compile-resources \
--sourcedir=$(srcdir) \
@@ -184,6 +194,8 @@ EXTRA_DIST = \
appstream-glib.gresource.xml \
appstream-glib.pc.in \
as-blacklist-ids.txt \
+ as-category-ids.txt \
+ as-environment-ids.txt \
as-license-ids.txt \
as-stock-icons.txt \
as-tag.gperf \