summaryrefslogtreecommitdiff
path: root/libappstream-glib/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2014-04-21 12:53:50 +0100
committerRichard Hughes <richard@hughsie.com>2014-04-21 12:53:50 +0100
commit6a8d7f2b3a817c0b69cf58432a1985bd9df8a221 (patch)
treefc5c2401a205d88b715afcde05467af682324229 /libappstream-glib/Makefile.am
parent7469f75841f1c335d93a11ec1192515022ad1961 (diff)
downloadappstream-glib-6a8d7f2b3a817c0b69cf58432a1985bd9df8a221.tar.gz
Add as_app_validate() to validate AppStream, AppData and desktop files
Diffstat (limited to 'libappstream-glib/Makefile.am')
-rw-r--r--libappstream-glib/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/libappstream-glib/Makefile.am b/libappstream-glib/Makefile.am
index d554eb0..c9834ed 100644
--- a/libappstream-glib/Makefile.am
+++ b/libappstream-glib/Makefile.am
@@ -7,6 +7,8 @@ endif
AM_CPPFLAGS = \
$(GLIB_CFLAGS) \
+ $(GDKPIXBUF_CFLAGS) \
+ $(SOUP_CFLAGS) \
-I$(top_srcdir)/libappstream-glib \
-I$(top_builddir)/libappstream-glib \
-I. \
@@ -68,6 +70,7 @@ libappstream_glib_include_HEADERS = \
libappstream_glib_la_SOURCES = \
as-app.c \
as-app-private.h \
+ as-app-validate.c \
as-enums.c \
as-image.c \
as-image-private.h \
@@ -95,7 +98,9 @@ endif
CLEANFILES = $(BUILT_SOURCES)
libappstream_glib_la_LIBADD = \
- $(GLIB_LIBS)
+ $(GLIB_LIBS) \
+ $(GDKPIXBUF_LIBS) \
+ $(SOUP_LIBS)
libappstream_glib_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -112,6 +117,8 @@ as_self_test_SOURCES = \
as-self-test.c
as_self_test_LDADD = \
$(GLIB_LIBS) \
+ $(GDKPIXBUF_LIBS) \
+ $(SOUP_LIBS) \
$(lib_LTLIBRARIES)
as_self_test_CFLAGS = $(WARNINGFLAGS_C)
@@ -120,6 +127,7 @@ TESTS = as-self-test
if HAVE_INTROSPECTION
introspection_sources = \
as-app.c \
+ as-app-validate.c \
as-app.h \
as-enums.c \
as-enums.h \