summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-07-13 17:44:35 +0200
committerRichard Hughes <richard@hughsie.com>2017-07-26 13:13:08 +0100
commit74e4b5105b7bee8755cfa1b628f9fcd36698f3f6 (patch)
tree94f75373eddeef3b680ed9190266f24a4199377b /meson.build
parent7e2b7a17ee0b670be33d9060e1c699db175b1c75 (diff)
downloadappstream-glib-74e4b5105b7bee8755cfa1b628f9fcd36698f3f6.tar.gz
meson: avoid unnecessary gdk dependency
gdk is only needed by the asb_plugin_font, which only gets built when both appstream-build and fonts are enabled. Therefore checking for the dependency should also be limited to that case, otherwise gdk has to be provided during compilation also in cases where it is not used at all. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b0912cc..c88bbdc 100644
--- a/meson.build
+++ b/meson.build
@@ -55,7 +55,6 @@ gmodule = dependency('gmodule-2.0', version : glib_ver)
giounix = dependency('gio-unix-2.0', version : glib_ver)
libarchive = dependency('libarchive')
soup = dependency('libsoup-2.4', version : '>= 2.51.92')
-gdk = dependency('gdk-3.0')
json_glib = dependency('json-glib-1.0')
gdkpixbuf = dependency('gdk-pixbuf-2.0', version : '>= 2.31.5')
libgcab = dependency('libgcab-1.0', required : false)
@@ -78,6 +77,7 @@ if get_option('enable-builder')
conf.set('HAVE_ALPM', 1)
endif
if get_option('enable-fonts')
+ gdk = dependency('gdk-3.0')
conf.set('HAVE_FONTS', 1)
freetype = dependency('freetype2', version : '>= 9.10.0')
fontconfig = dependency('fontconfig')