summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index dc04134..8777c11 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -21,6 +21,7 @@ AS_BUILDER_LIBS = \
$(top_builddir)/libappstream-builder/libappstream-builder.la
bin_PROGRAMS = \
+ appstream-compose \
appstream-util
if HAVE_BUILDER
@@ -57,4 +58,16 @@ appstream_builder_CFLAGS = \
$(WARNINGFLAGS_C)
endif
+appstream_compose_SOURCES = \
+ as-compose.c
+appstream_compose_LDADD = \
+ $(AS_GLIB_LIBS) \
+ $(GLIB_LIBS) \
+ $(SOUP_LIBS) \
+ $(LIBARCHIVE_LIBS)
+appstream_compose_LDFLAGS = \
+ $(PIE_LDFLAGS)
+appstream_compose_CFLAGS = \
+ $(WARNINGFLAGS_C)
+
-include $(top_srcdir)/git.mk