summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 448f866..976b3c6 100644
--- a/setup.py
+++ b/setup.py
@@ -16,21 +16,19 @@
import textwrap
import distutils.core
+import argparse
distutils.core.setup(
name='argparse',
- version='0.9.1',
+ version=argparse.__version__,
author='Steven Bethard',
author_email='steven.bethard@gmail.com',
url='http://code.google.com/p/argparse/',
- description='An optparse-inspired command-line parsing library',
+ description='Python command-line parsing library',
long_description = textwrap.dedent("""\
- Argparse takes the best of the optparse command-line parsing module
- and brings it new life. Argparse adds positional as well as
- optional arguments, the ability to create parsers for sub-commands,
- more informative help and usage messages, and much more. At the
- same time, it retains the ease and flexibility of use that made
- optparse so popular."""),
+ The argparse module provides an easy, declarative interface for
+ creating command line tools.
+ """),
license='Apache 2.0',
classifiers=[
'Development Status :: 4 - Beta',