summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ae7197c..ee1c9a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,6 @@ AC_TYPE_UINT64_T
# Checks for library functions.
AC_PROG_GCC_TRADITIONAL
-AC_FUNC_MEMCMP
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_SETVBUF_REVERSED
AC_TYPE_SIGNAL
@@ -59,7 +58,10 @@ case "$target_os" in
*linux*)
AC_LIBOBJ([findif_linux])
;;
- *bsd*)
+ *freebsd*|*openbsd*)
+ AC_LIBOBJ([findif_bsd])
+ ;;
+ *)
AC_LIBOBJ([findif_other])
;;
esac