summaryrefslogtreecommitdiff
path: root/atk-adaptor/Makefile.am
diff options
context:
space:
mode:
authorMark Doffman <mdoff@silver-wind.(none)>2009-01-12 11:49:58 +0000
committerMark Doffman <mdoff@silver-wind.(none)>2009-01-12 14:05:08 +0000
commitc5f078cefdda19b9b4a5e450c9e96855d2f12893 (patch)
tree9c5f2e2b1c765d3ddc3ffd07e327e5779f80066c /atk-adaptor/Makefile.am
parent9788269a68be7552c5a6faf8d5f47923ec496249 (diff)
downloadat-spi2-atk-c5f078cefdda19b9b4a5e450c9e96855d2f12893.tar.gz
2009-01-12 Mark Doffman <mark.doffman@codethink.co.uk>
* atk-adaptors/ Large code-structure refactor. D-Bus adaptors have been renamed to *-adaptor.c. atk-dbus.c has been renamed to accessible-register.c to better indicate its function. The marshalling code has been split out.
Diffstat (limited to 'atk-adaptor/Makefile.am')
-rw-r--r--atk-adaptor/Makefile.am46
1 files changed, 26 insertions, 20 deletions
diff --git a/atk-adaptor/Makefile.am b/atk-adaptor/Makefile.am
index 944681f..c47cefc 100644
--- a/atk-adaptor/Makefile.am
+++ b/atk-adaptor/Makefile.am
@@ -1,7 +1,10 @@
gtkmoduledir = $(libdir)/$(GTK_MODULE_DIR)
gtkmodule_LTLIBRARIES = libspiatk.la
-libspiatk_la_CFLAGS = $(DBUS_GLIB_CFLAGS) $(ATK_CFLAGS) -I$(top_srcdir)\
+libspiatk_la_CFLAGS = $(DBUS_GLIB_CFLAGS)\
+ $(ATK_CFLAGS)\
+ -I$(top_srcdir)\
+ -I$(top_srcdir)/atk-adaptor/adaptors\
-DATSPI_INTROSPECTION_PATH=\"$(pkgdatadir)/$(DEFAULT_ATSPI_INTROSPECTION_PATH)\"
libspiatk_la_LDFLAGS = -no-undefined \
@@ -15,25 +18,28 @@ libspiatk_la_LIBADD = $(DBUS_GLIB_LIBS) \
$(top_builddir)/spi-common/libspicommon.la
libspiatk_la_SOURCES = \
- accessible.h \
- accessible.c \
- action.c \
- application.c \
+ accessible-adaptor.c \
+ accessible-marshaller.c \
+ accessible-marshaller.h \
+ accessible-register.c \
+ accessible-register.h \
+ action-adaptor.c \
+ adaptor.h \
+ application-adaptor.c \
bridge.c \
bridge.h \
- collection.c \
- component.c \
- document.c \
- editabletext.c \
+ collection-adaptor.c \
+ component-adaptor.c \
+ document-adaptor.c \
+ editabletext-adaptor.c \
event.c \
- hyperlink.c \
- hypertext.c \
- atk-dbus.c \
- atk-dbus.h \
- image.c \
- selection.c \
- table.c \
- text.c \
- tree.c \
- tree.h \
- value.c
+ event.h \
+ hyperlink-adaptor.c \
+ hypertext-adaptor.c \
+ image-adaptor.c \
+ selection-adaptor.c \
+ table-adaptor.c \
+ text-adaptor.c \
+ tree-adaptor.c \
+ tree-adaptor.h \
+ value-adaptor.c