summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWillie Walker <william.walker@sun.com>2009-11-06 12:39:35 -0500
committerWillie Walker <william.walker@sun.com>2009-11-06 12:39:35 -0500
commitbeccc6ec73af048833f1b95b4b7e6e29cfabce13 (patch)
treeab7b009d9c24cf1d89f1c4fd966a0f2b2e246984 /configure.ac
parent627a65e9e16867bcb252597c79bded60dff9681b (diff)
downloadat-spi2-atk-beccc6ec73af048833f1b95b4b7e6e29cfabce13.tar.gz
Add --enable-relocate option
This option is similar to what we did for AT-SPI/CORBA. The default value is to not enable relocation. If enabled, however, the atk-bridge module is relocated and a *.desktop file is installed to initialize GTK_PATH in gnome-session so the new module can be found by GTK+.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f9df83a..81e2af0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,14 +78,11 @@ if test -z "$DEFAULT_ATSPI_INTROSPECTION_PATH"; then
DEFAULT_ATSPI_INTROSPECTION_PATH=dbus
fi
-AC_ARG_VAR([GTK_MODULE_DIR],
- [Where to place the atk-adaptor gtk module])
-if test -z "$GTK_MODULE_DIR"; then
- GTK_MODULE_DIR=gtk-2.0/modules
- AM_CONDITIONAL(RELOCATE, false)
-else
- AM_CONDITIONAL(RELOCATE, true)
+AC_ARG_ENABLE(relocate, [ --enable-relocate Relocate to coexist with CORBA [default=no]], enable_relocate="$enableval", enable_relocate=no)
+if test x$enable_relocate = xyes ; then
+ AC_DEFINE(RELOCATE, , [Relocate to coexist with CORBA])
fi
+AM_CONDITIONAL(RELOCATE, test x$enable_relocate = xyes)
#libtool option to strip symbols starting with cspi
LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^cspi]].*"'