summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Doffman <mark.doffman@codethink.co.uk>2010-01-05 01:47:34 -0800
committerMark Doffman <mark.doffman@codethink.co.uk>2010-01-05 02:21:17 -0800
commit5713a8e46559b6de9fbf5fc3e073d0d482d8c7e1 (patch)
treebcd5bec668df796becdcafb64131c2c4c887b245 /configure.ac
parent1dd7a3f08c3ac54abca261ae5aa539371f77ccc9 (diff)
downloadat-spi2-atk-5713a8e46559b6de9fbf5fc3e073d0d482d8c7e1.tar.gz
Integrate leasing scheme in-to atk-bridge.
This involved: Separating the 'cache' and registration of accessible objects. This is because the leased objects need to be available over D-Bus but are not cached. Separating the cache updating from the 'events'. This is because we should still recieve updates on leased accessibles, but they are not cached.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 11 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index aadf7f5..f16ff7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,26 +98,23 @@ fi
AC_SUBST(EXTRA_SOCKET_LIBS)
dnl find sizes & alignments
-orig_CPPFLAGS=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS $DBUS_CFLAGS"
-DBIND_CHECK_ALIGNOF(char)
-DBIND_CHECK_ALIGNOF(dbus_bool_t)
-DBIND_CHECK_ALIGNOF(dbus_int16_t)
-DBIND_CHECK_ALIGNOF(dbus_int32_t)
-DBIND_CHECK_ALIGNOF(dbus_int64_t)
-DBIND_CHECK_ALIGNOF(double)
-DBIND_CHECK_ALIGNOF(dbind_pointer)
-DBIND_CHECK_ALIGNOF(dbind_struct)
-CPPFLAGS=$orig_CPPFLAGS
+#orig_CPPFLAGS=$CPPFLAGS
+#CPPFLAGS="$CPPFLAGS $DBUS_CFLAGS"
+#DBIND_CHECK_ALIGNOF(char)
+#DBIND_CHECK_ALIGNOF(dbus_bool_t)
+#DBIND_CHECK_ALIGNOF(dbus_int16_t)
+#DBIND_CHECK_ALIGNOF(dbus_int32_t)
+#DBIND_CHECK_ALIGNOF(dbus_int64_t)
+#DBIND_CHECK_ALIGNOF(double)
+#DBIND_CHECK_ALIGNOF(dbind_pointer)
+#DBIND_CHECK_ALIGNOF(dbind_struct)
+#CPPFLAGS=$orig_CPPFLAGS
AC_CONFIG_FILES([Makefile
droute/Makefile
- dbind/Makefile
- dbind/dbind-config.h
common/Makefile
atk-adaptor/Makefile
atk-adaptor/adaptors/Makefile
- tests/Makefile
])
AC_OUTPUT