summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Welche <prlw1@cam.ac.uk>2011-05-20 12:35:15 +0100
committerPatrick Welche <prlw1@cam.ac.uk>2011-05-20 12:35:15 +0100
commit76eef82a0842f4db4d70aad466e8af5ca4ec3956 (patch)
tree8b6dc1f6b6276a00e4fb0267b18ee1859ca78f07 /configure.ac
parent53943482ff7b564d285dce98f0212918baf18bac (diff)
downloadat-spi2-atk-76eef82a0842f4db4d70aad466e8af5ca4ec3956.tar.gz
Build fixes.
- cache-adaptor.c makes use of AtkStateSet* . - atk-bridge uses X. - -Werror-implicit-function-declaration doesn't contain an equal sign in my copy of gcc, and is gcc specific.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 211bc57..23d868e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,10 @@ DBIND_CHECK_ALIGNOF(dbind_pointer)
DBIND_CHECK_ALIGNOF(dbind_struct)
CPPFLAGS=$orig_CPPFLAGS
+if test "x$GCC" = xyes; then
+ CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
+fi
+
if test "x$enable_p2p" = "xno"; then
P2P_CFLAGS=-DDISABLE_P2P
fi