summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gorse <mgorse@novell.com>2011-03-21 11:48:21 -0700
committerMike Gorse <mgorse@novell.com>2011-03-21 11:53:03 -0700
commitff4004bdb88bd2a6c4edfb2858188a9880dabb92 (patch)
treeeb947627ec2e7f341de2106a89567e3ecba84c0c /configure.ac
parent10144fcf6ea817879043e0994502a65a102289fd (diff)
downloadat-spi2-atk-ff4004bdb88bd2a6c4edfb2858188a9880dabb92.tar.gz
Use libatspi to get the accessibility bus and handle main loop integration
Remove function to get the accessibility bus, since it was duplicating code in at-spi2-core and should be modified for BGO#644851. Also, use atspi_dbus_*_setup_with_g_main instead of depending on dbus-glib, so that FDO#35115 doesn't show up and we don't need to disable p2p if an old version of dbus-glib is installed. Note that at-spi2-atk now depends on libatspi where previously it did not.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 4 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index f5149ba..cf47a18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,13 +43,6 @@ PKG_CHECK_MODULES(GLIB, [glib-2.0])
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
-PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.90, dbus_glib=yes, dbus_glib=no)
-if test "x$dbus_glib" = "xno"; then
- PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.7.0, dbus_glib_old=yes)
-fi
-AC_SUBST(DBUS_GLIB_LIBS)
-AC_SUBST(DBUS_GLIB_CFLAGS)
-
PKG_CHECK_MODULES(GOBJ, [gobject-2.0 >= 2.0.0])
AC_SUBST(GOBJ_LIBS)
AC_SUBST(GOBJ_CFLAGS)
@@ -62,6 +55,10 @@ PKG_CHECK_MODULES(ATK, [atk >= 1.29.3])
AC_SUBST(ATK_LIBS)
AC_SUBST(ATK_CFLAGS)
+PKG_CHECK_MODULES(ATSPI, [atspi-2 >= 1.91.92])
+AC_SUBST(ATSPI_LIBS)
+AC_SUBST(ATSPI_CFLAGS)
+
AC_PATH_XTRA
if test x$no_x = xyes ; then
@@ -102,10 +99,6 @@ DBIND_CHECK_ALIGNOF(dbind_pointer)
DBIND_CHECK_ALIGNOF(dbind_struct)
CPPFLAGS=$orig_CPPFLAGS
-if test "x$dbus_glib_old" = "xyes"; then
- P2P_CFLAGS=-DDISABLE_P2P
-fi
-
if test "x$enable_p2p" = "xno"; then
P2P_CFLAGS=-DDISABLE_P2P
fi
@@ -126,8 +119,3 @@ AC_CONFIG_FILES([Makefile
])
AC_OUTPUT
-
-if test "x$dbus_glib_old" = "xyes"; then
- P2P_CFLAGS=-DDISABLE_P2P
- AC_MSG_WARN([found dbus-glib older than 0.90; disabling peer-to-peer support])
-fi