summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Doffman <mark.doffman@codethink.co.uk>2010-01-05 12:50:55 -0800
committerMark Doffman <mark.doffman@codethink.co.uk>2010-01-05 12:50:55 -0800
commit0c6971bdf4c2c0f3e64580287cd17555c32881dd (patch)
tree813b196f4d4f8ef731caacf338ba3ff74a97588c /configure.ac
parent5713a8e46559b6de9fbf5fc3e073d0d482d8c7e1 (diff)
downloadat-spi2-atk-0c6971bdf4c2c0f3e64580287cd17555c32881dd.tar.gz
Fix object lifecycle errors.
Add an application reference to the event structure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f16ff7f..38f905c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,19 +98,21 @@ fi
AC_SUBST(EXTRA_SOCKET_LIBS)
dnl find sizes & alignments
-#orig_CPPFLAGS=$CPPFLAGS
-#CPPFLAGS="$CPPFLAGS $DBUS_CFLAGS"
-#DBIND_CHECK_ALIGNOF(char)
-#DBIND_CHECK_ALIGNOF(dbus_bool_t)
-#DBIND_CHECK_ALIGNOF(dbus_int16_t)
-#DBIND_CHECK_ALIGNOF(dbus_int32_t)
-#DBIND_CHECK_ALIGNOF(dbus_int64_t)
-#DBIND_CHECK_ALIGNOF(double)
-#DBIND_CHECK_ALIGNOF(dbind_pointer)
-#DBIND_CHECK_ALIGNOF(dbind_struct)
-#CPPFLAGS=$orig_CPPFLAGS
+orig_CPPFLAGS=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS $DBUS_CFLAGS"
+DBIND_CHECK_ALIGNOF(char)
+DBIND_CHECK_ALIGNOF(dbus_bool_t)
+DBIND_CHECK_ALIGNOF(dbus_int16_t)
+DBIND_CHECK_ALIGNOF(dbus_int32_t)
+DBIND_CHECK_ALIGNOF(dbus_int64_t)
+DBIND_CHECK_ALIGNOF(double)
+DBIND_CHECK_ALIGNOF(dbind_pointer)
+DBIND_CHECK_ALIGNOF(dbind_struct)
+CPPFLAGS=$orig_CPPFLAGS
AC_CONFIG_FILES([Makefile
+ dbind/dbind-config.h
+ dbind/Makefile
droute/Makefile
common/Makefile
atk-adaptor/Makefile