summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in240
1 files changed, 0 insertions, 240 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 76206df..0000000
--- a/configure.in
+++ /dev/null
@@ -1,240 +0,0 @@
-AC_INIT(xml/Accessibility.xml)
-
-AT_SPI_MAJOR_VERSION=1
-AT_SPI_MINOR_VERSION=22
-AT_SPI_MICRO_VERSION=0
-AT_SPI_INTERFACE_AGE=0
-AT_SPI_BINARY_AGE=0
-AT_SPI_VERSION="$AT_SPI_MAJOR_VERSION.$AT_SPI_MINOR_VERSION.$AT_SPI_MICRO_VERSION"
-AM_INIT_AUTOMAKE(at-spi, $AT_SPI_VERSION)
-AC_SUBST(AT_SPI_MAJOR_VERSION)
-AC_SUBST(AT_SPI_MINOR_VERSION)
-AC_SUBST(AT_SPI_MICRO_VERSION)
-AC_SUBST(AT_SPI_INTERFACE_AGE)
-AC_SUBST(AT_SPI_BINARY_AGE)
-
-# libtool versioning
-LT_RELEASE=$AT_SPI_MAJOR_VERSION.$AT_SPI_MINOR_VERSION
-LT_CURRENT=10
-LT_REVISION=11
-LT_AGE=10
-LT_VERSION_INFO='-version-info ${LT_CURRENT}:${LT_REVISION}:${LT_AGE}'
-AC_SUBST(LT_VERSION_INFO)
-AC_SUBST(LT_RELEASE)
-AC_SUBST(LT_CURRENT)
-AC_SUBST(LT_REVISION)
-AC_SUBST(LT_AGE)
-
-dnl required versions of other tools.
-m4_define([req_ver_atk], [1.17.0])
-m4_define([req_ver_gtk], [2.10.0])
-m4_define([req_ver_gail], [1.9.0])
-m4_define([req_ver_dbus_glib], [0.7.0])
-
-dnl Specify a header configuration file
-AM_CONFIG_HEADER(config.h)
-
-dnl Initialize maintainer mode
-AM_MAINTAINER_MODE
-
-dnl translation of any at-spi strings: used only for .server
-IT_PROG_INTLTOOL([0.35.0])
-
-dnl Checks for programs
-AC_PROG_CC
-AC_PROG_INSTALL
-AC_ISC_POSIX
-
-# Check for Python
-
-AM_PATH_PYTHON(2.4)
-
-GNOME_COMMON_INIT
-GNOME_COMPILE_WARNINGS(maximum)
-
-dnl Initialize libtool
-AM_DISABLE_STATIC
-AM_PROG_LIBTOOL
-
-GETTEXT_PACKAGE="${PACKAGE}"
-AC_SUBST(GETTEXT_PACKAGE)
-dnl internationalization support; uncomment if translatable strings are reintroduced
-AM_GLIB_GNU_GETTEXT
-
-# AM_GLIB_GNU_GETTEXT above subst. $DATADIRNAME
-# this is the directory where the *.{mo,gmo} files are installed
-localedir='${prefix}/${DATADIRNAME}/locale'
-AC_SUBST(localedir)
-
-GTK_DOC_CHECK([1.0])
-
-AC_PATH_XTRA
-
-if test x$no_x = xyes ; then
- AC_MSG_ERROR([X development libraries not found])
-else
- X_LIBS="$X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS"
-fi
-
-AC_SUBST(X_LIBS)
-
-dnl Check for obsolete (mis-numbered) versions of at-spi
-dnl oldlibs=`echo $(libdir)/libspi.so.1.*`
-dnl if test $$oldlibs != "$(libdir)/libspi.so.1.*" ; then
-dnl AC_MSG_ERROR(Old libspi.1.x library found in $libdir. Please remove $(libdir)/libspi.so.1 and $$oldlibs)
-dnl fi
-
-dnl Checks for libraries
-PKG_CHECK_MODULES(LIBSPI, [
- dbus-glib-1 >= req_ver_dbus_glib
- atk >= req_ver_atk
-])
-AC_SUBST(LIBSPI_LIBS)
-AC_SUBST(LIBSPI_CFLAGS)
-
-PKG_CHECK_MODULES(REGISTRYD, [
- dbus-glib-1 >= req_ver_dbus_glib
- atk >= req_ver_atk
- gtk+-2.0 >= req_ver_gtk
-])
-AC_SUBST(REGISTRYD_LIBS)
-AC_SUBST(REGISTRYD_CFLAGS)
-
-PKG_CHECK_MODULES(TESTS, [
- dbus-glib-1 >= req_ver_dbus_glib
- atk >= req_ver_atk
- gtk+-2.0 >= req_ver_gtk
- gail >= req_ver_gail
-])
-AC_SUBST(TESTS_LIBS)
-AC_SUBST(TESTS_CFLAGS)
-
-PKG_CHECK_MODULES(ATK_BRIDGE, [
- dbus-glib-1 >= req_ver_dbus_glib
- atk >= req_ver_atk
-])
-AC_SUBST(ATK_BRIDGE_LIBS)
-AC_SUBST(ATK_BRIDGE_CFLAGS)
-
-PKG_CHECK_MODULES(LIBCSPI, [
- dbus-glib-1 >= req_ver_dbus_glib
- atk >= req_ver_atk
-])
-AC_SUBST(LIBCSPI_LIBS)
-AC_SUBST(LIBCSPI_CFLAGS)
-
-PKG_CHECK_MODULES(ORBIT, [
- ORBit-2.0
-])
-AC_SUBST(ORBIT_LIBS)
-AC_SUBST(ORBIT_CFLAGS)
-
-dnl orbit-idl.
-ORBIT_IDL="`$PKG_CONFIG --variable=orbit_idl ORBit-2.0`"
-AC_SUBST(ORBIT_IDL)
-
-LIBS="$LIBS $X_LIBS"
-dnl path to Xtst
-AC_CHECK_LIB(Xtst, XTestFakeKeyEvent, XTST_LIBS=-lXtst,[
- AC_MSG_ERROR([Couldn't find the Xtst library. Check config.log])],
- -lX11 -lXext)
-AC_SUBST(XTST_LIBS)
-
-have_xkb=
-AC_CHECK_LIB(X11, XkbQueryExtension, have_xkb="maybe")
-if test "x$have_xkb" = "xmaybe"; then
- AC_CHECK_HEADER(X11/XKBlib.h, have_xkb=yes)
-fi
-if test "x$have_xkb" = "xyes"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_XKB)
-fi
-
-have_xinput=
-AC_CHECK_LIB(Xi, XOpenDevice, XINPUT_LIBS=-lXi,,-lXext)
-if test "x$XINPUT_LIBS" = x; then
- AC_MSG_ERROR(Couldn't find the XInput library. Check config.log for details)
-fi
-AC_CHECK_HEADER(X11/extensions/XInput.h, have_xinput=yes)
-AC_SUBST(XINPUT_LIBS)
-
-dnl Allow disabling XEViE.
-AC_ARG_ENABLE(xevie, [ --enable-xevie Build with XEViE support [default=yes]], enable_xevie="$enableval", enable_xevie=yes)
-
-if test x$enable_xevie = xyes ; then
- have_xevie=
- AC_CHECK_LIB(Xext, XevieStart, have_xevie="yes")
-
- if test "x$have_xevie" = "xyes"; then
- XEVIE_LIBS="-lXext"
- AC_DEFINE(HAVE_XEVIE)
- else
- AC_CHECK_LIB(Xevie, XevieQueryVersion, have_xevie="maybe",,-lXevie -lXext)
- if test "x$have_xevie" = "xmaybe"; then
- AC_CHECK_HEADER(X11/extensions/Xevie.h, have_xevie=yes, [], [#include <X11/Xlib.h>])
- if test "x$have_xevie" = "xyes"; then
- XEVIE_LIBS="-lXext -lXevie"
- AC_DEFINE(HAVE_XEVIE)
- fi
- fi
- fi
- AC_SUBST(XEVIE_LIBS)
-fi
-
-dnl CFLAGS="$CFLAGS -Wall"
-AC_SUBST(CFLAGS)
-AC_SUBST(CPPFLAGS)
-AC_SUBST(LDFLAGS)
-
-AC_CHECK_LIB(popt, poptGetContext, [POPT_LIBS="-lpopt"],
-AC_MSG_ERROR([popt is required to build at-spi.
-You can download the latest version from ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/]))
-AC_SUBST(POPT_LIBS)
-AC_MSG_CHECKING([for POPT_ARG_FLOAT in popt.h])
-AC_TRY_CPP([#include <popt.h>
-#ifndef POPT_ARG_FLOAT
-#error popt too old
-#endif], AC_MSG_RESULT(yes), [
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([A newer version of popt is required to build at-spi.
-You can download the latest version from ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/])
-])
-
-#libtool option to strip symbols starting with cspi
-#
-LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^cspi]].*"'
-AC_SUBST(LIBTOOL_EXPORT_OPTIONS)
-
-REBUILD=\#
-if test "x$enable_rebuilds" = "xyes" && \
- test -n "$PERL" && \
- $PERL -e 'exit !($] >= 5.002)' > /dev/null 2>&1 && \
- test -n "$AWK" ; then
- REBUILD=
-fi
-AC_SUBST(REBUILD)
-
-AC_OUTPUT([
-Makefile
-po/Makefile.in
-libspi-1.0.pc
-libspi-1.0-uninstalled.pc
-libloginhelper-1.0.pc
-cspi-1.0.pc
-cspi-1.0-uninstalled.pc
-atk-bridge/Makefile
-libspi/Makefile
-registryd/Makefile
-tools/Makefile
-xml/Makefile
-])
-
-echo "AT-SPI setup:
-
- Source code location: ${srcdir}
- Compiler: ${CC}
- Prefix: ${prefix}
-
- Welcome to the wonderful world of Accessibility.
- http://developer.gnome.org/projects/gap/
-"