summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build99
1 files changed, 55 insertions, 44 deletions
diff --git a/atk/meson.build b/atk/meson.build
index 1d2a49c..4760df8 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -34,7 +34,6 @@ atk_sources = [
]
atk_headers = [
- 'atk.h',
'atkaction.h',
'atkcomponent.h',
'atkdocument.h',
@@ -43,12 +42,13 @@ atk_headers = [
'atkhyperlink.h',
'atkhyperlinkimpl.h',
'atkhypertext.h',
+ 'atkimage.h',
+ 'atkmisc.h',
'atknoopobject.h',
'atknoopobjectfactory.h',
'atkobject.h',
'atkobjectfactory.h',
'atkplug.h',
- 'atkimage.h',
'atkrange.h',
'atkregistry.h',
'atkrelation.h',
@@ -63,12 +63,11 @@ atk_headers = [
'atktablecell.h',
'atktext.h',
'atkutil.h',
- 'atkmisc.h',
'atkvalue.h',
'atkwindow.h',
]
-install_headers(atk_headers, subdir: atk_api_path)
+install_headers(atk_headers + ['atk.h'], subdir: atk_api_path)
# Features header
atk_version_conf = configuration_data()
@@ -81,24 +80,26 @@ atk_version_conf.set('LT_CURRENT_MINUS_AGE', '0')
atk_version_conf.set('ATK_VERSION', meson.project_version())
atk_version_h = configure_file(input: 'atkversion.h.in',
- output: 'atkversion.h',
- configuration: atk_version_conf,
- install: true,
- install_dir: join_paths(atk_includedir, atk_api_path))
+ output: 'atkversion.h',
+ configuration: atk_version_conf,
+ install_dir: join_paths(atk_includedir, atk_api_path),
+)
# Marshallers
atk_marshals = gnome.genmarshal('atkmarshal',
- sources: 'atkmarshal.list',
- prefix: 'atk_marshal')
+ sources: 'atkmarshal.list',
+ prefix: 'atk_marshal',
+)
atk_marshal_h = atk_marshals[1]
# Enumerations for GType
atk_enums = gnome.mkenums('atk-enum-types',
- sources: atk_headers,
- c_template: 'atk-enum-types.c.template',
- h_template: 'atk-enum-types.h.template',
- install_dir: join_paths(atk_includedir, atk_api_path),
- install_header: true)
+ sources: atk_headers,
+ c_template: 'atk-enum-types.c.template',
+ h_template: 'atk-enum-types.h.template',
+ install_dir: join_paths(atk_includedir, atk_api_path),
+ install_header: true,
+)
atk_enum_h = atk_enums[1]
atk_cflags = [
@@ -120,36 +121,46 @@ if host_system == 'windows'
atk_sources += atk_win_res
endif
-atk_inc = include_directories('.')
-
-libatk = library('atk-@0@'.format(atk_api_version),
- sources: atk_sources + atk_enums + atk_marshals,
- soversion: atk_soversion,
- version: atk_libversion,
- install: true,
- dependencies: glib_dep,
- include_directories: [ root_inc, atk_inc ],
- c_args: common_cflags + atk_cflags,
- link_args: common_ldflags)
+libatk = library(atk_api_name,
+ sources: atk_sources + atk_enums + atk_marshals,
+ soversion: atk_soversion,
+ version: atk_libversion,
+ install: true,
+ dependencies: glib_dep,
+ include_directories: [ root_inc, atk_inc ],
+ c_args: common_cflags + atk_cflags,
+ link_args: common_ldflags,
+)
-libatk_dep = declare_dependency(link_with: libatk,
- include_directories: [atk_inc, root_inc],
- dependencies: glib_dep,
- sources: atk_enum_h)
+atk_sources_dep = [ atk_enum_h ]
if get_option('introspection')
- gnome.generate_gir(libatk,
- sources: atk_sources + atk_headers + [ atk_enum_h ] + [ atk_version_h ],
- namespace: 'Atk',
- nsversion: atk_api_version,
- identifier_prefix: 'Atk',
- symbol_prefix: 'atk',
- export_packages: 'atk',
- includes: [ 'GObject-2.0' ],
- install: true,
- extra_args: [
- '--quiet',
- '--c-include=atk/atk.h',
- '-DATK_COMPILATION',
- ])
+ atk_sources_dep += gnome.generate_gir(libatk,
+ sources: atk_sources + atk_headers + [ atk_enum_h ] + [ atk_version_h ],
+ namespace: 'Atk',
+ nsversion: atk_api_version,
+ identifier_prefix: 'Atk',
+ symbol_prefix: 'atk',
+ export_packages: 'atk',
+ includes: [ 'GObject-2.0' ],
+ install: true,
+ extra_args: [
+ '--quiet',
+ '--c-include=atk/atk.h',
+ '-DATK_COMPILATION',
+ ],
+ )
endif
+
+libatk_dep = declare_dependency(link_with: libatk,
+ include_directories: atk_inc,
+ dependencies: glib_dep,
+ sources: atk_sources_dep,
+)
+
+pkgconfig.generate(libatk,
+ name: 'Atk',
+ description: 'Accessibility Toolkit',
+ subdirs: atk_api_name,
+ filebase: 'atk',
+)