summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/atk/meson.build b/atk/meson.build
index 042cd54..4760df8 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -121,7 +121,7 @@ if host_system == 'windows'
atk_sources += atk_win_res
endif
-libatk = library('atk-@0@'.format(atk_api_version),
+libatk = library(atk_api_name,
sources: atk_sources + atk_enums + atk_marshals,
soversion: atk_soversion,
version: atk_libversion,
@@ -157,3 +157,10 @@ libatk_dep = declare_dependency(link_with: libatk,
dependencies: glib_dep,
sources: atk_sources_dep,
)
+
+pkgconfig.generate(libatk,
+ name: 'Atk',
+ description: 'Accessibility Toolkit',
+ subdirs: atk_api_name,
+ filebase: 'atk',
+)