summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build27
1 files changed, 16 insertions, 11 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 1fbb992..7c1f3ab 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -6,15 +6,20 @@ tests = [
'testvalue',
]
-foreach t: tests
- bin = executable(t, t + '.c',
- dependencies: libatk_dep,
- include_directories: root_inc,
- c_args: common_cflags + [
- '-DG_DISABLE_DEPRECATED',
- ])
- test(t, bin, env: [
- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
- ])
+foreach test_name: tests
+ test_src = test_name + '.c'
+ test_bin = executable(test_name, test_src,
+ dependencies: libatk_dep,
+ include_directories: root_inc,
+ c_args: common_cflags + [
+ '-DG_DISABLE_DEPRECATED',
+ ],
+ )
+
+ test(test_name, test_bin,
+ env: [
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ ],
+ )
endforeach