summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-02-15 18:40:06 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-02-15 18:42:20 +0100
commitfd0ca827e7acbbb89aed74f057e4c23a4223f3b3 (patch)
treee58a40489ef55e1934d713b73a7f7a9f2293b3c1 /Makefile.am
parent8f41580e5d039d9549f7e73f51c2e82de4075015 (diff)
parent43b8af82db9fb7077ae687998bf96e9781460665 (diff)
downloadautomake-fd0ca827e7acbbb89aed74f057e4c23a4223f3b3.tar.gz
Merge branch 'maint'
* maint: maint: add a rule to use gnulib's update-copyright
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 83071f157..323d93d7f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -340,7 +340,8 @@ config.guess \
config.sub \
gnupload \
gitlog-to-changelog \
-texinfo.tex
+texinfo.tex \
+update-copyright
## Fetch the latest versions of files we care about.
fetch:
@@ -353,6 +354,7 @@ fetch:
$(WGET_SV_CVS)texinfo/texinfo/doc/texinfo.tex -O texinfo.tex && \
$(WGET_SV_GIT_GL)doc/INSTALL -O INSTALL && \
$(WGET_SV_GIT_GL)build-aux/gnupload -O gnupload && \
+ $(WGET_SV_GIT_GL)build-aux/update-copyright -O update-copyright && \
$(WGET_SV_GIT_GL)build-aux/gitlog-to-changelog -O gitlog-to-changelog)
## Don't exit after test because we want to give as many errors as
## possible.
@@ -369,3 +371,12 @@ fetch:
echo "See Fetchdir/update.patch for a log of the changes."; \
exit $$stat
.PHONY: fetch
+
+update_copyright_env = \
+ UPDATE_COPYRIGHT_FORCE=1 \
+ UPDATE_COPYRIGHT_USE_INTERVALS=2
+
+.PHONY: update-copyright
+update-copyright:
+ git ls-files | grep -Ev 'COPYING|INSTALL' \
+ | $(update_copyright_env) xargs $(srcdir)/lib/$@