summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-01-15 23:38:58 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-01-15 23:48:42 +0100
commit3b594a8cc0fa3e8835e4f79b68515fe4e7b72a78 (patch)
tree0768d45cfbdbfed19f656e9723fdd5fb072ef2a8 /Makefile.am
parent8856653ec87c826ec5f7f7c577e01afaa64c3ed5 (diff)
downloadautomake-3b594a8cc0fa3e8835e4f79b68515fe4e7b72a78.tar.gz
maint: remove obsolete/broken maintainer targets
* Makefile.am (git-diff): Remove. First, we don't distribute diffs between an automake version and the next one anyway, so this target is pointless. Moreover, its recipe has been broken for quite a long time now, always generating an empty diff due to the spurious '$(PACKAGE)' argument that was passed to the "git diff" invocation. (path-check): Remove. The 'pathchk' program running in this check complains about any file with name longer than 14 characters, which is a ridiculously low limit for today standards. Also, we already had several test scripts (no less than 195!) that were exceeding that limit, and nobody ever complained (not even on MinGW/MSYS nor Cygwin).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index e8330f544..afed46afc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -623,27 +623,6 @@ git-release: git-dist
$(srcdir)/lib/gnupload $(GNUPLOADFLAGS) \
--to $$dest.gnu.org:automake $(DIST_ARCHIVES)
-git-diff:
- $(AM_V_GEN):; \
- thisver="v$(VERSION)"; \
- if test -z "$$OLDVERSION"; then \
- prevno=`echo "$(VERSION)" - 0.01 | bc | sed 's/^\./0./'`; \
- else prevno="$$OLDVERSION"; fi; \
- prevver=v$$prevno; \
- git diff $$prevver..$$thisver $(PACKAGE) \
- > $(PACKAGE)-$$prevno-$(VERSION).diff
-
-## Check our path lengths.
-path-check: distdir
- $(AM_V_GEN)($(am__cd) $(distdir) && \
-## FIXME there's got to be a better way! pathchk should take the list
-## of files on stdin, at least.
- find . -print | xargs pathchk -p); \
- estatus=$$?; \
- find $(distdir) -type d '!' -perm -200 -exec chmod u+w {} ';'; \
- rm -rf $(distdir); \
- exit $$estatus
-
## Visually comparing differences between the Makefile.in files in
## automake's own build system as generated in two different branches
## might help to catch bugs and blunders. This has already happened a