summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-02-15 18:47:15 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-02-15 18:47:44 +0100
commit7726b2e999d2064546f258db607233ae3aac04f1 (patch)
tree148fee36dfee75bfcde7ee7f1008aac22d1b6c1c /Makefile.am
parentfd0ca827e7acbbb89aed74f057e4c23a4223f3b3 (diff)
downloadautomake-7726b2e999d2064546f258db607233ae3aac04f1.tar.gz
maint: prefer $(GIT) over hard-coded "git" in maintainer recipes
* Makefile.am (update-copyright, autodiffs): Use '$(GIT)' instead of hard-coding 'git'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 323d93d7f..e87bd2480 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -269,9 +269,9 @@ autodiffs:
{ \
rev=$$1 dir=$$2 \
&& echo "$@: will get files from revision $$rev" \
- && git clone -q --depth 1 "$$am_gitdir" tmp \
+ && $(GIT) clone -q --depth 1 "$$am_gitdir" tmp \
&& $(am__cd) tmp \
- && git checkout -q "$$rev" \
+ && $(GIT) checkout -q "$$rev" \
&& echo "$@: bootstrapping $$rev" \
&& $(SHELL) ./bootstrap \
&& echo "$@: copying files from $$rev" \
@@ -283,8 +283,8 @@ autodiffs:
}; \
outdir=$@.dir \
## Before proceeding, ensure the specified revisions truly exist.
- && git --git-dir="$$am_gitdir" describe $$OLD_COMMIT >/dev/null \
- && git --git-dir="$$am_gitdir" describe $$NEW_COMMIT >/dev/null \
+ && $(GIT) --git-dir="$$am_gitdir" describe $$OLD_COMMIT >/dev/null \
+ && $(GIT) --git-dir="$$am_gitdir" describe $$NEW_COMMIT >/dev/null \
&& rm -rf $$outdir \
&& mkdir $$outdir \
&& $(am__cd) $$outdir \
@@ -378,5 +378,5 @@ update_copyright_env = \
.PHONY: update-copyright
update-copyright:
- git ls-files | grep -Ev 'COPYING|INSTALL' \
+ $(GIT) ls-files | grep -Ev 'COPYING|INSTALL' \
| $(update_copyright_env) xargs $(srcdir)/lib/$@